20.11.2017
  • Módulo Materia
  •  
  • Meldezeitpunkt
  • Montag, 28.07.2014 23:20
  • Last Change
  • Montag, 18.01.2016 22:03
  • Estatus
  • Fijo
  • Texto
  • Moin,

    (hier stand vorher ein Report für einen behobenen Bug)

    aktuell wird nur ein HTTPS-Registierungslink generiert, wenn der User die Seite per HTTPS besucht. Wäre dafür, dass dies standard ist, sobald eine HTTPS-Adresse konfiguriert ist.

Kommentare
     
    MaLuZ
    31.07.2014 19:19
    Geänderter Code hierfür:

    class_usrmgr.php, Zeile 18 und folgend:
    Code:

            //Use the HTTPS party URL if defined, otherwise check what the user is currently using
            if ($cfg['sys_partyurl_ssl']){
                    $verification_link = $cfg['sys_partyurl_ssl'];
                    //make sure that it ends with a slash
                    if (substr($cfg['sys_partyurl_ssl'],-1,1) !='/') $verification_link .=  '/';
                    $verification_link .= "index.php?mod=usrmgr&action=verify_email&verification_code=$verification_code";
            }
            else{
                    if (!empty($_SERVER['HTTPS']) && $_SERVER['HTTPS'] !== 'off' || $_SERVER['SERVER_PORT'] == 443) $proto = 'https';
                    else $proto = 'http';
                    $verification_link = "{$proto}://{$_SERVER['SERVER_NAME']}:{$_SERVER['SERVER_PORT']}{$path}index.php?mod=usrmgr&action=verify_email&verification_code=$verification_code";
            }
     

    quote
    MaLuZ
    18.01.2016 22:03
    Ist im GIT-Fork.. quote
    Entradas de 1%
    • Hinweis:
      Bitte loggen dich ein, bevor du einen Kommentar verfasst
    • Hinweis:
      No se ha encontrado ningún resultado