25.04.2014
  • Betrifft Modul
  • tournament2
  • Meldezeitpunkt
  • Donnerstag, 01.09.2011 22:09
  • Letzte Änderung
  • Samstag, 28.04.2012 11:53
  • Status
  • Behoben
  • Text
  • Hallo zusammen
    auf unser letzten Lan hatten wir in einem Cup das Problem das im Winnerbracket auf einmal in beiden Runden Freilos gegen Freilos gespielt haben.
    Was bräuchtet ihr für daten um den fehler zu finden?
    Sollte bei der nächsten lan in ca 4 Wochen nicht mehr vorkommen.


Kommentare
     
    KnoX
    02.09.2011 12:54
    Avatar
    Am besten einen dump der kompletten DB. Zumindest aber die tournament_* t2_* und user tabellen.

    Habe aber momentan leider keine Zeit für Lansuite. Werde es mir in den 4 Wochen daher leider nicht ansehen können.

    http://www.orgapage.de - Infoseite für LanParty-Orgas
    [Equipmentliste | Strom-/Netzplanung | Intranetsysteme | Game- und Dienste-Servertipps]
    quote
    FlAsHdRiVe
    02.09.2011 13:06
    ok schade.... vielleicht hast nen tip wonach wir schauen müssen habe nen kleinen php freak an der hand ;-) quote
    FlAsHdRiVe
    02.09.2011 14:07
    habe gerade festgestellt egal was ich eintrage ab winner bracket kommt immer Freilos gegen freilos...
    könnte das mal jemand testen ob es bei euch auch so ist?
    quote
    Dr[Karl]
    02.09.2011 15:55
    Kannst Du mal einen Screenshot vom Baum anhängen? quote
    FlAsHdRiVe
    02.09.2011 19:43
    Hier sind se....



    Aber in der db wird nix eingetragen als ob er die ergebnisse aus den gruppen nicht ermittel !!!
    quote
    FlAsHdRiVe
    02.09.2011 23:24
    könnte uns jemand ne idee geben wo wir suchen sollen suchen uns gerade nen wolf.... quote
    Dr[Karl]
    05.09.2011 13:28
    Hi,

    ich bin mit dem Spielsystem net vertraut, weil wir das noch nie eingesetzt haben, von daher kann ich da aus'm Stand net so viel dazu sagen.

    Aber was mir an den zwei Screenshots so auffällt:
    - Ich seh' keine Freilose im Winner-Bracket - genaugenommen sehe ich gar nix beim Winner-Bracket
    - Im Screenshot 'paarungen.jpg' ist bei Gruppe1,Runde2 kein Ergebnis drin bei einer Begegnung...
    im baum.jpg allerdings steht da ein Ergebnis drin? Das passt irgendwie net zusammen

    habt Ihr mal probiert, ob es einen Unterschied macht, wenn es keine Unentschieden gibt bei den Einzelspielen?
    Vielleicht wurde das nicht berücksichtigt, dass es bei so Gruppenspielen auch Unentschieden geben kann...


    Gruß
    Dr.
    quote
    FlAsHdRiVe
    05.09.2011 16:16
    nein haben alles möglichen szenarien durchprobiert mit diversen ergebnissen es kommt immer freilos vs freilos bei raus.
    ist auf den screenshots untergegangen da ich immer wieder neue möglichkeiten probiert habe....
    mach eifach mal nen faketurnier auf ergebnisse rein dann fällt es gleich auf ;-)

    gruß flash
    quote
    Dr[Karl]
    06.09.2011 00:50
    Was für eine Version von LS benutzt Ihr denn?

    Ich hab's probiert mit der aktuellen svn Version und bei mir funktioniert es wie erwartet.

    KnoX hat im Sept. 2010 (also nach dem Release der 4.1b) das turniermodul nochmal geändert mit folgendem Eincheck-Kommentar:

    Code:
    Im Turniermodus groups wurden die Gewinner nicht korrekt in die KO Runde eingetragen. Fix SQL-Fehler, wenn Server-Modul nicht aktiv
     


    Ich gehe jetzt fast davon aus, dass das genau der Fix zu Eurem Problem war...

    Gruß
    dr.
    quote
    FlAsHdRiVe
    27.09.2011 18:33
    ok werde mir noch mal das aktuellste pack laden und noch einmal testen

    update:
    Also habe gerade mit der 4.0 als auch mit der 4.1beta den gleichen fehler reproduzieren können
    Jetzt noch jemand eine idee????



    update 2:
    habe gerade noch mal die 4.1b frisch auf meinem homeserver installiert und exact der gleiche fehler !?!?!

    verstehe es ned

    update 3:
    gerade ist mir noch aufgefallen das aud der homeseite viel zu viele begegnungen angezeigt werden und dem pulldown "Spielpaarungen"
    könnte da der fehler liegen oder ist das ein anderer BUG ?
    quote
    KnoX
    28.09.2011 08:33
    Avatar
    Wenn du die Version updatest, musst du aber auch das Turnier neu generieren und alle Ergebnise neu eintragen, damit es überhaupt eine Wirkung hat.

    Denn bereits in der Vergangenheit falsch zugeordnete Begegnungen tut die neue Version nicht grade ziehen.

    http://www.orgapage.de - Infoseite für LanParty-Orgas
    [Equipmentliste | Strom-/Netzplanung | Intranetsysteme | Game- und Dienste-Servertipps]
    quote
    Dr[Karl]
    30.09.2011 08:01
    Hallo nochmal,

    ein Update auf 4.1b wird auch keine Besserung bringen. Ich habe ja geschrieben, dass der Fix von KnoX NACH der 4.1b im SVN eingebaut wurde.

    D.h. es gibt im Moment kein Package, das den Fix enthält.
    Du müsstest auf Deiner 4.1b Installation den Patch von KnoX selber updaten (oder auf das nächste Release?!? der LS warten).

    Die beiden betroffenen Dateien bzw. die Änderung ist hier zu finden:

    http://code.google.com/p/lansuite/source/detail?r=2302

    Gruß
    dr.
    quote
    FlAsHdRiVe
    04.10.2011 17:03
    ok werde die files dann mal ersetzen ;-) quote
    Dr[Karl]
    07.11.2011 21:48
    Hi FlAsHdRiVe,

    kannst Du bestätigen, dass das Problem mit obigem Fix von KnoX erledigt ist?

    Dann könnte man nämlich diesen Punkt hier schließen.

    Gruß
    dr.
    quote
    KnoX
    28.04.2012 11:53
    Avatar
    Hab auf behoben gesetzt, da kein Feedback mehr gekommen ist.
    http://www.orgapage.de - Infoseite für LanParty-Orgas
    [Equipmentliste | Strom-/Netzplanung | Intranetsysteme | Game- und Dienste-Servertipps]
    quote
    15 Einträge
    • Hinweis:
      Bitte loggen dich ein, bevor du einen Kommentar verfasst
    Eintrag #5297 in Tabelle "lansuite_comments" eingefügt KnoX 02.09.11
    12:54
    Eintrag #5298 in Tabelle "lansuite_comments" eingefügt FlAsHdRiVe 02.09.11
    13:06
    Eintrag #5299 in Tabelle "lansuite_comments" eingefügt FlAsHdRiVe 02.09.11
    14:07
    Eintrag #5300 in Tabelle "lansuite_comments" eingefügt Dr[Karl] 02.09.11
    15:55
    Eintrag #5301 in Tabelle "lansuite_comments" eingefügt FlAsHdRiVe 02.09.11
    19:43
    Eintrag #5301 in Tabelle "lansuite_comments" geändert FlAsHdRiVe 02.09.11
    20:26
    Eintrag #5301 in Tabelle "lansuite_comments" geändert FlAsHdRiVe 02.09.11
    20:27
    Eintrag #5302 in Tabelle "lansuite_comments" eingefügt FlAsHdRiVe 02.09.11
    23:24
    Eintrag #5303 in Tabelle "lansuite_comments" eingefügt Dr[Karl] 05.09.11
    13:28
    Eintrag #5304 in Tabelle "lansuite_comments" eingefügt FlAsHdRiVe 05.09.11
    16:16
    Eintrag #5305 in Tabelle "lansuite_comments" eingefügt Dr[Karl] 06.09.11
    00:50
    Eintrag #5306 in Tabelle "lansuite_comments" eingefügt FlAsHdRiVe 27.09.11
    18:33
    Eintrag #5306 in Tabelle "lansuite_comments" geändert FlAsHdRiVe 27.09.11
    19:04
    Eintrag #5306 in Tabelle "lansuite_comments" geändert FlAsHdRiVe 27.09.11
    19:09
    Eintrag #5306 in Tabelle "lansuite_comments" geändert FlAsHdRiVe 27.09.11
    19:12
    Eintrag #5306 in Tabelle "lansuite_comments" geändert FlAsHdRiVe 27.09.11
    19:12
    Eintrag #5306 in Tabelle "lansuite_comments" geändert FlAsHdRiVe 27.09.11
    19:54
    Eintrag #5306 in Tabelle "lansuite_comments" geändert FlAsHdRiVe 27.09.11
    21:03
    Eintrag #5309 in Tabelle "lansuite_comments" eingefügt KnoX 28.09.11
    08:33
    Eintrag #5313 in Tabelle "lansuite_comments" eingefügt Dr[Karl] 30.09.11
    08:01
    Eintrag #5316 in Tabelle "lansuite_comments" eingefügt FlAsHdRiVe 04.10.11
    17:03
    Bugreport auf Status "Feedback benötigt" geändert Dr[Karl] 07.11.11
    21:46
    Benachrichtigungsmail an Reporter versandt Dr[Karl] 07.11.11
    21:46
    Eintrag #5326 in Tabelle "lansuite_comments" eingefügt Dr[Karl] 07.11.11
    21:48
    Bugreport auf Status "Behoben" geändert KnoX 28.04.12
    11:53
    Benachrichtigungsmail an Reporter versandt KnoX 28.04.12
    11:53
    Bugreport Benutzer "KnoX" zugeordnet KnoX 28.04.12
    11:53
    Eintrag #5440 in Tabelle "lansuite_comments" eingefügt KnoX 28.04.12
    11:53
    28 Einträge